首页 / 浏览问题 / 移动GIS / 问题详情
库文件的文件偏移量大于或等于文件大小?
30EXP 2023年07月31日
错误代码: Process: com.example.supermap_project, PID: 12388
    java.lang.UnsatisfiedLinkError: dlopen failed: library "libQt5Core.so" not found: needed by /data/app/~~WMMbZgBdEWwiGYIk2prSWQ==/com.example.supermap_project-0CZvTLUhmi4T250i9vF1zQ==/lib/arm/libimb_v1110.so in namespace classloader-namespace
        at java.lang.Runtime.loadLibrary0(Runtime.java:1077)
        at java.lang.Runtime.loadLibrary0(Runtime.java:998)
        at java.lang.System.loadLibrary(System.java:1656)
        at com.supermap.data.Environment.checkAndLoadLibrary(Environment.java:1663)
        at com.supermap.data.Environment.initialization(Environment.java:585)
        at com.example.supermap_project.GpsloadActivity.onCreate(GpsloadActivity.java:104)
        at android.app.Activity.performCreate(Activity.java:8485)
        at android.app.Activity.performCreate(Activity.java:8463)
        at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1329)
        at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:3929)
        at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:4113)
        at android.app.servertransaction.LaunchActivityItem.execute(LaunchActivityItem.java:103)
        at android.app.servertransaction.TransactionExecutor.executeCallbacks(TransactionExecutor.java:135)
        at android.app.servertransaction.TransactionExecutor.execute(TransactionExecutor.java:95)
        at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2458)
        at android.os.Handler.dispatchMessage(Handler.java:106)
        at android.os.Looper.loopOnce(Looper.java:233)
        at android.os.Looper.loop(Looper.java:334)
        at android.app.ActivityThread.main(ActivityThread.java:8395)
        at java.lang.reflect.Method.invoke(Native Method)
        at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:582)
        at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:1065)

1个回答

您好,这些libQt开头的库文件以及libgnustl_shared需要添加到工程中去的
3,235EXP 2023年07月31日

一开始就添加了,就出现了这个错误

看你这里添加的没有libQt开头的库文件,你再检查下
...