首页 / 浏览问题 / 组件GIS / 问题详情
UE4 4.26.2/4.27.2 使用插件中C++API后打包失败,编译正常
5EXP 2022年11月21日

使用产品:SuperMap Hi-Fi 3D SDK 11i(2022) SP1 for Unreal 操作系统:win10 x64
数据类型: 文件型
问题详细描述:UE4 4.26.2/4.27.2 使用插件中C++API后打包失败,编译正常,代码在编辑器下可以正常运行
问题重现步骤:1、按照操作手册:配置UE4 场景

2、使用自己的C++代码调用插件中的C++ api ,vs编译和UE热编译都正常,代码在编辑器下可以正常运行

3、打包windows的exe,直接打包失败,显示Unknown Error ,没有别的日志信息

备注:我们公司想在gis方向做一些软件,目前刚开始的功能需求不是很复杂,主要是gis定位功能,测试过cesium和arcgis的插件,但是还是倾向于用国产自己的插件和服务,如果有经过测试的稳定的unity和UE版本,请留言给我说一下,可以长期合作

问题关闭原因: 不是问题

1个回答

您好,

使用 UE4.26 打包的时候,需要删除 Web427 文件哈。

另外,使用我们demo打包的时候有报错嘛?
715EXP 2022年11月21日
使用你们自己的场景的话,估计会打包成功,我按照操作手册,试过不使用插件API的场景,可以打包,但是我在自己的C++脚本里面, 用了你们接口参考里面的API后,不能成功打包:主要使用的代码  :     Scene*   scene = RealspaceView::GetSingleton()->GetSceneControl()->GetScene(); scene->Fly(cameraState, 300);    你们可以试下,新建C++脚本,调用这个API,可以成功吗?
我们是一个SDK,提供了Demo叫做插件,界面功能都是我们提供的Demo。您可以打开我们插件的c++工程进行参考哈。
所以,你们新建工程,新建C++脚本,调用这个插件的c++的API,可以成功打包吗?
我们的插件就是一个示例哦,可以参考一下哦,是可以成功的呢。
...