imobile更新到最新版本的问题

0 投票

您好,我把app从10.0.1更新到10.1.1之后,会出现如下问题,请问问题可能发生在哪儿,如何解决

以下是我的开发包(由于需要用到三维场景以及二维查询的功能,所以集成进了lite的包)

之前升级过几次,最后都解决了,这次升级报出了“ java.lang.IllegalArgumentException: so库和jar包版本不匹配”的错误,由于项目时间比较紧,所以希望能快速得到回复以解决问题,麻烦了

1月 20 分类:  41次浏览 | 用户: enbir 初出茅庐 (80 分)

1个回答

0 投票
 
已采纳
您好,检测下您那边工程的build.grandle文件里面的grandle版本是多少?建议降低grandle版本,可以设置为3.2.0版本
1月 20 用户: 董懿鑫 登峰造极 (6,964 分)
采纳于 1月 20 用户:enbir
之前的gradle版本一直就是5.1.1的,为什么超图的api更新了,反而需要降低gradle的版本;问题是3.2的版本太低了,很多android的新特性没办法使用。
...