so库和jar包版本不匹配

0 投票
使用产品:imobile 9D 912 操作系统:win10 x64

问题详细描述:使用超图imobile和百度SDK,出现so库和jar包版本不匹配

问题: Process: com.example.uidemo, PID: 4867
    java.lang.RuntimeException: Unable to start activity ComponentInfo{com.example.uidemo/com.example.uidemo.activity.ShowActivity}: java.lang.IllegalArgumentException: so库和jar包版本不匹配
        at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:3364)
        at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:3548)
        at android.app.servertransaction.LaunchActivityItem.execute(LaunchActivityItem.java:86)
        at android.app.servertransaction.TransactionExecutor.executeCallbacks(TransactionExecutor.java:108)
        at android.app.servertransaction.TransactionExecutor.execute(TransactionExecutor.java:68)
        at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2155)
        at android.os.Handler.dispatchMessage(Handler.java:109)
        at android.os.Looper.loop(Looper.java:207)
        at android.app.ActivityThread.main(ActivityThread.java:7539)
        at java.lang.reflect.Method.invoke(Native Method)
        at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:524)
        at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:958)
     Caused by: java.lang.IllegalArgumentException: so库和jar包版本不匹配
7月 25 分类:  60次浏览 | 用户: moqian (5 分)

1个回答

0 投票
您好,根据报错信息从以下方面排查:

1、确认导入的工程中libs中的so库和jar包是否同一个版本;

2、确认许可是否正常,测试手机的设备系统时间是否正常;

3、运行工程前将原来已生成的该软件卸载,再重新运行安装。

4、如果还是有问题,建议你删除导致那个不兼容的同名文件,可以删超图的jar包或者第三方sdk中的,根据自己的功能需求而定。
7月 26 用户: 董懿鑫 名扬四海 (2,926 分)
...