react项中 echarts 5版本,构建时报错

0 投票
把echarts升级到5版本后,在构建时引入的supermap包报echarts引入方式错误,错误提示如下:

./node_modules/@supermap/iclient-common/components/chart/ChartView.js
Attempted import error: 'echarts' does not contain a default export (imported as 'echarts').
3月 30 分类:  174次浏览 | 用户: angel (2 分)

1个回答

0 投票
 
已采纳

你好  可能是echarts-for-react不支持新版本的echarts,可以参考博客: https://blog.csdn.net/qq_45742208/article/details/111318819

3月 30 用户: johnJJ 才高八斗 (842 分)
采纳于 3月 30 用户:angel
echarts还原到4.9版本,已经可以了,谢谢
...