SuperMap iObjects .NET 支持的mysql数据库版本

0 投票
使用产品:supermap-iobjectsdotnet-10.0.1-18027-76100

操作系统:win10 x64

数据库:mysql 8.0

你好,请问supermap-iobjectsdotnet(不一定是上面的版本)是否支持mysql 8.0的数据库?
7月 3 分类:  25次浏览 | 用户: 璐璐8889 才疏学浅 (15 分)
重新分类 7月 3 用户:三次鱼疯啦

1个回答

0 投票

MySQL 8.0版本是支持的,但是MySQL8.0采用了新的更安全的验证方式,所以按照之前版本默认安装后会出现新建数据源失败的情况。针对这个情况,可以采用下面方法去解决:


使用mysql进入控制台,然后输入ALTER USER root@localhost IDENTIFIED WITH mysql_native_password BY '111111';,然后调用下命令FLUSH PRIVILEGES;将user表中信息立即同步到内存中;


让用户是按照mysql_native_password这种方式来连接就可以了,如下图:

7月 3 用户: 程逸诗 名扬四海 (2,452 分)
好的,谢谢
...