10i的iobject.net组件和9d的能够在一个vs中兼容吗

0 投票
使用产品:iobject.net9d和iobject.net 10i   操作系统 win10 x64

数据类型:文件型

你好,我想问一下,我能把超图9d和10i两个版本的组件安装在电脑的同一个vs里吗,两个工具项,都能拉控件。

或者我现在安装10i.net组件以后,在电脑上运行以前用9d.net开发的软件代码能用吗?
1月 8 分类:  122次浏览 | 用户: amstring 初出茅庐 (58 分)

1个回答

0 投票
您好,需要切换环境变量,如果你那边用9D的,需要把9D的bin包放在环境变量path最前端。如果换成10i的,需要把10i的bin包放在path最前端。
1月 9 用户: 邬袁凯 名扬四海 (2,432 分)
哦,好的,谢谢,我试试,我还想问一下,为什么9d的程序10i组件运行不了,咱们的gis开发为什么不考虑版本能够向下兼容呢。
您好,一般不建议跨版本的,因为跨版本了有的接口会改动的。但是完全运行不了是不可能的。

你那边可以查看环境变量的问题,你换成10i组件包过后有没有把系统环境变量path最前端修改成10i的呢?   还有,你在9d的项目引用dll项有没有改成10i的组件呢?
...