so库和jar包版本不匹配

0 投票
89 浏览
同样的代码在Android API22 5.1系统上可以正常运行,在Android API 21 5.0系统上就报错

so库和jar包版本不匹配,用的是IMobile for Android 9D 900版本的jar包和900的so库 如何解决这个问题啊?测试用的手机都是Vivo厂商的
最新提问 2月 1 分类:  89次浏览 | 用户: xykj (0 分)

1个回答

0 投票
运行的代码是一样的嘛,设备目录有许可吗?首先确保在gradle文件已配置jar和so的依赖,其次保证程序对设备有读取的权限,建议在设备应用管理里开启对该apk的信任及读取权限,最后开起wifi,确保能读取到设备id进行许可验证。如果依然有错,将错误日志贴出来。
最新回答 2月 2 用户: 杨兵 学富五车 (572 分)
...